Arquivos Mensais: fevereiro 2016

Os Intervalos Reais E Sua Aplicação Na Lógica De Programação

Prof. Inácio Wanderley

e-mail: inaciouemanet@gmail.com

Hoje a computação tem evoluído com uma magnitude que chega a assombrar pesquisadores, por que há um grande consumo de produtos lançados que alcançam alarmantes índices para a vida das pessoas. Existe uma febre crescente de pessoas que se valem deste tipo de ferramenta para as suas transações bancárias, compras pela internet e até na hora de pedir uma pizza já existem serviços oferecidos por restaurantes e pizzarias que utilizam o nome em inglês “DELIVERY”  para chamar a atenção e tornar a vida de pessoas que vivem em grandes centros mais cômoda onde as mesmas no conforto do seu lar podem pedir de tudo o que quiserem somente tocando na tela de um Smartphone ou mesmo acessando um site em um PC – leia-se “computador pessoal”. Mas a pergunta que as pessoas às vezes fazem é: – O que está por trás dessa tecnologia que torna tudo tão rápido e preciso, fazendo milhões de informações serem processadas em poucos segundos com uma margem mínima de erro?

Utilizando esse argumento iremos fazer uma explanação a respeito de um dos assuntos pouco visto pelas pessoas como valioso, mas que no seu pano de fundo aplica-se perfeitamente ao nosso dia-a-dia no tocante à computação.

Estaremos falando sobre intervalos de números reais e sua aplicação na computação, principalmente na construção de algoritmos que utilizam a lógica como argumento principal.

INTERVALO

Conceito:

Um intervalo (real) é um conjunto que contém cada número real entre dois extremos indicados, podendo ou não conter os próprios extremos. Por exemplo: um conjunto cujos elementos são maiores ou iguais a 0(zero) e menores ou iguais a 1               (isto é, 0 ≤ x ≤ 1, sendo x um elemento qualquer pertencente ao conjunto em questão) é um intervalo que contém os extremos 0(zero) e 1, bem como todos os números reais entre eles. Outros exemplos de intervalos são o conjunto dos números reais  e o conjunto dos números reais negativos.

Os extremos podem ser números reais como também podem ser  e . Existem divergências na literatura sobre se o conjunto vazio deveria ser ou não ser considerado um intervalo. Quando o conjunto vazio é considerado um intervalo, a família de intervalos é fechada sobre a operação de intersecção

Representação:

Notações comuns para representar intervalos são:

Quando aplicamos isso vemos a importância deste assunto em soluções rápidas e eficazes. Uma das melhores aplicações que podemos ver acerca de INTERVALOS é quando usamos ESTRUTURAS LÓGICAS e ESTRUTURAS DE DECISÃO em linguagem de programação. Tomemos o seguinte exemplo utilizando o portugol:

Construa um algoritmo que peça as 4(quatro) notas bimestrais de matemática um aluno, calcule a sua média aritmética, exiba a nota e a situação dele, como reprovado, de recuperação ou aprovado. A média de aprovação é 7,0, a média de recuperação está entre 5,0 e 7,0 e a média de reprovação estará abaixo de 5,0.

Iremos utilizar o programa Visualg para construir esse algoritmo

 

 

 

 

algoritmo “Calculo da média de um aluno”

 

var

n1, n2, n3, n4, res : real

inicio

escreval(“Digite a primeira nota do aluno :”)

leia(n1)

escreval(“Digite a segunda nota do aluno :”)

leia(n2)

escreval(“Digite a terceira nota do aluno :”)

leia(n3)

escreval(“Digite a quarta nota do aluno :”)

leia(n4)

 

res <- (n1 + n2 + n3 + n4)/4

 

se (res < 5) entao

escreval(“a media do aluno foi “,res,” e o aluno esta reprovado”)

senao

se (res >= 5) e (res < 7) entao

escreval(“a media do aluno foi “,res,” e o aluno esta de recuperação”)

senao

se (res >= 7) entao

escreval(“a media do aluno foi “,res,” e o aluno esta aprovado”)

 

fimse

fimse

fimse

 

fimalgoritmo

 

 

Tela do aplicativo

 

 

Depois do algoritmo pronto iremos agora comentar passo a passo a aplicação dos intervalos, limitando o nosso raciocínio da linha 17 até a 24 de nosso algoritmo. Ilustraremos isso usando a representação gráfica de intervalos.

Quando o programa pede para se digitar 4(quatro) notas, calcular a sua média e exibir a nota e a situação do aluno, ele estará usando a estrutura de decisão para fazer um teste lógico e verificar através de intervalos a referida situação. Vejamos isso usando a representação gráfica:

 

 

 

Imagem dos Intervalos

Bom pessoal, essa era a ideia que eu queria passar pra vocês. Um forte abraço e até a próxima.

 

 


Se esse artigo foi útil pra você, deixe seu comentário,sua opinião, curta e compartilhe essa informação com amigos!

Um forte abraço Professor Deivison Silva.